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Conventions Used in This Manual  

Typographic Convention 

Type Style Represents 

Example Text Words or characters that appear on the window.  These include field 
names, window titles, and pushbuttons. 

Example Text Words or characters you type into a field. 

 

Abbreviation Convention 

Abbreviation Represents 

N  Normal view of the content item editor 

A Advanced view of the content item editor 

 

Document Icons 

Icon Icon Meaning 

 

Tip ï a tip is a type of note that helps the users apply the techniques 
and procedures described in the test to their specific needs.  A tip 
suggests an alternative method that may not be obvious and helps 
users understand the benefits and capabilities of the item. 

 
Note ï Notes call the userôs attention to information of special 
importance. 

 
Reference ï Refers the user to another source of information. 

 
Caution ï Caution advises users of actions that could potentially 
cause problems. 

 

Illustrations used in this documentation were captured in Windows XP. Thus the appearance of windows and dialog boxes may vary 
slightly from that of other versions of Windows or on a Macintosh computer. The usage possibilities of this software are constantly 
evolving. The results presented in this handbook as examples may vary according to your version of the software. 
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THIS DOCUMENTATION IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS 
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL 
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, 
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER 
IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF 
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. COPYRIGHT HOLDERS WILL 
NOT BE LIABLE FOR ANY DIRECT, INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF ANY USE OF 
THE SOFTWARE OR DOCUMENTATION.  

Windows, MacIntosh, Quicktime, Flash, WebEQ and Real Video are registered trademarks of their respective owners. 
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Introduction  

Welcome to the ANGEL 7.3 HTML Reference Manual. This guide is designed to provide 
instructors students and mentors with an understanding of the HTML Editor.  

ANGELôs editor is a full What You See Is What You Get (WYSIWYG) HTML editor specifically 
designed to work within the ANGEL LMS.  The editor is present any place text can be formatted 
or edited. 

Notable features include: 

 Full WYSIWYG editing everywhere youôre able to edit content within ANGEL. 

 Simple menu options allow you find and link to any other content item within your course 
or the World Wide Web.   

 The Insert Image tool features an integrated file / web browser with the ability to select a 
graphic, seamlessly upload it to the course, and then insert the photo into the document. 

 Content template support allows for the creation of course content with a consistent look 
and feel. 

 Integrated equation editor from industry-leader WebEQ 

 Full table support makes it easier to present complex tabular data. 

 Paste from MS Word feature allows you to paste into your HTML editor directly from MS 
Word. 

 Edit window automatically resizes as you enter text ï allowing the window to start small 
and expand dynamically as you add text. 

Accessing Menus  

The  HTML editor is a toolbar which contains a menu of tools which will help you enhance your 
pages within ANGEL. The editor has three modes that are implemented to best support the 
userôs current task: 

 Full Menu ï The menu bar with all 32 menu features active. 

 Partial Menu ï the menu bar with 16 menu features active. Available in ANGELôs 
Announcement Editor, Page Banner, Data management nugget, Page Folder, 
Institutional Resource nugget, Did you know nugget, About this section nugget, Course 
News and Events nugget and Syllabus nugget. 

 Slim Menu ï the menu bar with 13 menu features active. Available in ANGELôs Calendar 
feature. 
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The  HTML editor includes the following menus and tools: 

 

 

A B C D E F G H I J K L M N 

 

Letter Menu/Tool Description Full Partial   Slim 

A  Collapse/Expand 
toolbar arrow 

Allows you to hide the HTML editor 
toolbar 

V    

B  Macro Icon Allows you to create and edit macros. V  V  V  

C  Edit menu Allows you to cut, copy, paste, 
undo/redo, find, replace, select all and 
remove. 

V  V  V  

D  Font Style menu Allows you to bold, underline, italicize, 
strikethrough, superscript and subscript 
text. 

V  Bold, italic and 
underline only 

Bold, italic 
and 
underline 
only 

E  Link menu Allows you to enter content and web 
links, remove links and create anchors. 

V  Content link, web 
link only 

Content link, 
web link only 

F  Media menu Allows you to insert and format images, 
movies and Flash presentations. 

V  Images  

G  Insert menu Allows you to use an HTML Widget, 
create and modify equations, insert 
special characters, use the universal 
keyboard, insert lines and page breaks. 

V  Equation editor 
and special 
characters only 

Equation 
editor only 

H  Table menu Allows you to manipulate rows, columns 
and cells.  

V    

I  Form menu Allows you to create forms using 
elements such as buttons, text fields 
and form parameters. 

V    

J  List menu Allows you to add bullets, numberings 
and indents. 

V  Numbered and 
bulleted only 

Numbered 
and bulleted 
only 

K  Justify menu Allows you to justify your text either left, 
right, center or block. 

V    

L  Text & 
Background color 

Allows you to change your text and 
background colors. 

V    

M  Formatting & 
Styles arrow 

Allows you to change your styles, fonts, 
font size and format your text. 

V  Font and Size only Font and 
Size only 

N  File Menu Allows you to view HTML source code, 
spell check, preview, save or change 

V  Spell check only Spell check 
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document properties. only 

 

 

You will need to disable pop-up blocking features to use some tools in the HTML 
editor. Failing in disable pop-up blocking may result in loss of information in the HTML 
editor and failure of the HTML Editing features. 

Using the Toolbar  and Menus  

Before you can begin using the HTML editor, you need to be able to access the menus. 

Access a menu  

To access a menu, do the following: 

 Click the Ƹ symbol to expand the menu, then click the tool (e.g. cut, copy, past, web 
link, etc.) 

Access a  tool  

To access a tool, do one of the following: 

 Click the tool icon in the toolbar.  

 Click the Ƹ symbol to expand the menu, then click the tool (e.g. cut, copy, past, web 
link, etc.) 

Collapse the toolbar  

To collapse the toolbar, do the following: 

 Click the Collapse toolbar arrow to hide ANGEL ôs HTML toolbar. 

Expand the toolbar  

To collapse the toolbar, do the following: 

 Click the Expand toolbar arrow to show ANGEL ôs HTML toolbar. 
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Formatting and Editing Text a nd Paragraphs  

You can format text and paragraphs as you would use a word processor ð to add visual 
organization, emphasis, and structure. You can change the font, size, style, color and add 
effects such as underlining. You can also control indentation, add bullets and numbers, and set 
alignment. 
 

The formatting you apply can either affect selected words or an entire paragraph. A general rule 
is that font properties (such as font, size, color and effects) can be applied to selected text, and 
paragraph properties (including alignment, bullets, numbering and formatting) affect entire 
paragraphs. For example, you can italicize a single word in a paragraph, but if you try to align 
the word to the right, the entire paragraph will be aligned. 
 

The editing tools you can use include the ability to copy, cut and paste words, sentences, and 
paragraphs as plain text or with full Word formatting.  

Formatting individual characters and words  

Properties that you can set for words or characters include:  

Icon Description 

 

 

Bold ï accentuates the text.  This text is bold. 

 

 

Italic ï causes the text to slant. This text is in italics. 

 

 

Underline ï places a line under the text. This text is underlined. 

 
Strikethrough ï places a line through the text.  This text is 
strikethough. 

 
Superscript ï places the text slightly higher than other text on a 
line, such as a footnote reference mark. This text is superscript. 

 
Subscript ï places the text slightly lower than other text on a line. 
Subscripts are often used in scientific formulas.  This text is subscript. 

 
Color ï allows you to affect the color of text. 

 
Background color- allows you to add highlight to selected text. 

 
Style - Is as a set of pre-defined formatting instructions that you 
can use repeatedly throughout the document.  
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Icon Description 

 
Font ï affects how text appears on a page. Font will default to 
browsers default  (usually Times New Roman or Times (on Macs). 

 
Font Size ï affects the size of the text on a page.  

Apply bold formatting    

1. Select the text you want to change.  

2. Do one of the following: 

 Click Bold . 

 On the Font Style menu, select Bold . 

Apply italic fo rmatting     

1. Select the text you want to change.  

2. Do one of the following: 

 Click Italic . 

 On the Font Style menu, select Italic . 

 Apply underline forma tting    

1. Select the text you want to change.  

2. Do one of the following: 

 Click Underline . 

 On the Font Style menu, select Underline . 

Apply strikethrough formatting  

1. Select the text that you want to change.  

2. On the Font Style Menu of the toolbar, select Strike Through  

. 

Apply superscript  text formatting    

1. Select the text that you want to change. 

2. On the Font Style Menu of the toolbar, select Superscript . 

Apply subscript  text formatting    
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1. Select the text that you want to change. 

2. On the Font Style Menu of the toolbar, select Subscript . 

Change the color of text  

The text color properties affect the color of text. It can be used on a specific character or a 
whole page.  

1. Select the text you want to change.  

2. Click Text Color   

3. Click the color you want. 
 

. 

 

 

You can select more colors by clicking More Colors, pointing to the color you want, 
and by clicking it. Once youôve selected a color, it will show in the selected box. If 
you select another color, it will show in the highlighted box only until you click OK. 
To clear the selected color from within the color picker, click Clear. 

If you do not highlight text, your chosen text color will apply to items typed from 
that point onwards. 

 

Change the background color of text    

1. Select the text you want to change.  

2. Click Background Color .  

3. Click the color you want. 
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You can select more colors by clicking More Colors, selecting the color you want, 
and by clicking it. Once youôve selected a color, it will show in the Selected box. If 
you select another color, it will show in the Highlighted box only until you click 
OK. To clear the selected color from within the Select Color dialog box, click 
Clear. 

If you do not select text, your chosen text color will apply to items typed from that 
point onwards. 

Apply a diffe rent text style    

1. Select the text you want to change.  

2. Click the Style icon. 

3. Select the style you want.   

 

 
The Style properties contain both character and paragraph styles.  To apply the 
style to only the selected text, select a style with the word Text in the title. 

 

Apply a different font to text    

1. Select the text you want to change.  

2. Click Font . 

3. Select the font you want. 
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The current font is annotated by the  symbol. 

Change the size of text    

1. Select the text you want to change.  

2. Click Size . 

3. Select the font you want. 

    

Formatting paragraphs  

Properties that you can set for paragraphs include:  

Icon Description 

 
 

 

Indentation determines the distance of the paragraph from either 
the left or right margins.  

 

 

 

 

 

 

Left or right justify-determines the appearance and orientation of 
the edges of the paragraph: left-aligned, right-aligned, centered, or 
justified (justify: To adjust horizontal spacing so that text is aligned 
evenly along both the left and right margins.  

 

 
Format-allows you to select preselected text and heading format 
options from a drop-down list. 

Indent  

Indentation determines the distance of the paragraph from the left margin. 
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Increase the left indent of an entire paragraph  

1. Place the insertion point into the paragraph you want to change.  

2. On the List menu, select Increase Indent . 

Decrease the left indent of an entire paragraph  

1. Place the insertion point into the paragraph you want to change.  

2. On the List menu, select Decrease Indent . 

 

Align pa ragraphs horizontally on the page  

Left Align Text 

1. Place the insertion point into the paragraph you want to align to the left of the page. 

2. On the Justify menu, select Left Justify . 

Right Align Text 

1. Place the insertion point into the paragraph you want to align to the right of the page 

2. On the Justify menu, select Right Justify . 

Center Align Text 

1. Place the insertion point into the paragraph you want to align to the center of the page. 

2. Click Center Justify . 

Block Align Text 

1. Place the insertion point into the paragraph you want to align along both the left and right 
of the page. 

2. Click the arrow on the Justify Menu, select Block Justify . 

Start a new line within the same paragraph  

A line break ends the current line and continues the text on the next line of the same paragraph.  

1. Place the insertion point where you want to create a new line. 

2. Press SHIFT+ENTER.  

Format 

1. Place the insertion point into the paragraph you want to format. 

2. Click Format . 
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3. Click the text format you want. 
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Formatting Bulleted, Number ed, and Multi -level Lists  

You can add bullets or numbers to existing lines of text, or you can automatically create bulleted 
and numbered lists as you type.  

 

Icon Description 

 
Numbered lists display a sequential list of items.  

 

 
Bulleted list display a list of unordered items.  

 

Numbered list  

Numbered lists display a sequential list of items.  You can select from uupper and lowercase 
letters, numbers, or upper and lowercase Roman numerals.  

 

Lettered List Numbered List Roman Numeral List 

a. Do this first  

b. Do this second 

c. Do this third 

1. Do this first  

2. Do this second 

3. Do this third 

I. Do this first  

II. Do this second 

III. Do this third 

Create a numbered list  

1. Place insertion point at the target location.  

2. Click Insert/Remove Numbered List . 

3. Type the text you want to add next to the number, and then press ENTER.  

4. To end the list, press ENTER again. 

Create a numbered list using existing text  

1. Do one of the following: 

 Select the items to which you want to add numbering. 

 Place insertion point at the target location.  

2. Click Insert/Remove Numbered List . 

3. To end the list, press ENTER again. 

Format numbered list  

1. Right-click any item in the numbered list you want to change. 
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2. In the pop-up menu, click Numbered List Properties . 
 

3. In the Numbered List Properties: 

 

a. Type the number to start the list in the Start box. 

b. Select the number format you want from the Type drop-down list. 

c. Click OK. 

 
Click Cancel to exit the window without making changes. 

Remove a numbered list  

1. Select the text from which you want numbers removed.  

2. Click Insert/Remove Numbered List . 

 
To remove a single number, click the number, and then press BACKSPACE. 

Bulleted list  

Bulleted list are used to present a list of unordered items ð that is, items that don't need to be 
numbered.  You can select from circle, disc or square bullets. 

 

Disc List Circle List Square List 

 apples  

 melons  

 grapes 

o apples  

o melons  

o grapes 

Á apples  

Á melons  

Á grapes 
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Create a bulleted list  

1. Place insertion point at the target location.  

2. Click Insert/Remove Bulleted List . 

3. Type the text you want to add next to the bullet, and then press ENTER.  

4. To end the list, press ENTER again. 

Create a bulleted list using existing text  

1. Do one of the following: 

 Select the items to which you want to add bullets. 

 Place insertion point at the target location.  

2. Click Insert/Remove Bulleted List . 

3. To end the list, press ENTER again. 

Format bulleted list  

1. Right-click any item in the bulleted list you want to change. 

2. In the pop-up menu, click Bulleted List Properties . 

3. In the Bulleted List Properties: 

 

a. Select the list format you want from the Type drop-down list. 

b. Click OK. 

 
Click Cancel to exit the window without making changes. 

 

Remove a bulleted list  

1. Select the text from which you want bullets removed.  

2. Click Insert/Remove Bulleted List . 

 
To remove a single bullet, click the number, and then press BACKSPACE. 
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Multilevel list  

You can create lists that have multiple nested levels and specify different list formats for each 
level. For example, the following list uses different numbering styles at each level. 

Multilevel Numbered List Multilevel Bulleted List 

1. Chapter  

a. Heading  

i. Topic  

1. Detail  

ii. Topic  

1. Detail  

2. Detail  

b. Heading  

 

 Chapter  

o Heading  

Á Topic  

 Detail  

Á Topic  

 Detail  

 Detail  

o Heading  

 

 

Create a multilevel list  

1. Place insertion point at the target location. 

2. Click either Insert/Edit Numbered List  or Insert/Edit Bulleted List .  

3. For each item you want in the list, regardless of its level, type the item, and then press 
ENTER.   

4. When you have typed the last item, press ENTER twice to end the list.  

5. To place each item on the correct level, do one of the following:  

 To move items down to the next level, select the items, and then click Increase 

Indent .  

 To move items up to the previous level, select the items, and then click Decrease 

Indent .  

6. To apply list formats to the different levels, do one of the following: 

 Format numbered list: 

a. Right-click any item in the list you want to change. 
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b. In the pop-up menu, click the Numbered List Properties. 

         

c. In the Numbered List Properties: 

 

i. Type the number to start the list in the Start box. 

ii. Select the number format you want from the Type drop-down list. 

iii. Click OK. 

 

 Format bulleted list:    

a. Right-click any item in the list you want to change. 

b. In the pop-up menu, click the Bulleted List Properties. 

            

c. In the Bulleted List Properties: 

           

i. Select the list format you want from the Type drop-down list. 

ii. Click OK. 
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Editing Text  and Paragraphs  

The Edit Menu is used to make changes to your text. Using the same type of features as a word 
processing program, you can  

 undo or redo an action  

 cut, copy or paste sections of text and images 

 paste text as plain text or with Word formatting 

 find, replace, or select all text 

 remove formatting from text 

Within this group of tasks the Paste function is represented as and icon. All functions are 

accessed through the Edit Menu . 

 

Icon Description 

 
Undo- allows you to undo the most recent action taken.  

 
Redo- allows you to redo the most recent action taken.  

 
Cut- allows you to Remove the highlighted text.  

 
Copy- allows you to copy the highlighted text.  

 
Paste- Paste the text you copied (with or without formatting)  

 
Paste as plain text- allows you to remove formatting from text before 
pasting it into the text area. 

 
Paste from Word- allows you to paste text from Word into the HTML 
editor retaining the exact replica of the Word document. You should 
always use this option when copying from Word. 

 
Find- allows you to find specific words or phrases for editing or 
deletion. 

 
Replace- allows you to replace words or phrases with new wording. 

 
Select All- allows you to select the entire text to format. 

 
Remove Format- allows you to remove all formatting from text. 

 

Undo  

Undo reverses the last action you performed in the HTML editor. Undo has a twin feature called 
Redo. You can undo 15 levels of actions. 
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 Click the arrow on the Edit Menu, select Undo . 

Redo  

Redo reverses the last Undo action. If you accidentally undo too many actions, Redo puts them 
back into your page. You can redo 15 levels of actions. 

 Click the arrow on the Edit Menu, select Redo . 

Cut  

1. Select text you want to cut. 

2. On the Edit Menu, select Cut . 

Copy  

1. Select text you want to cut. 

2. On the Edit Menu, select Copy . 

Paste  

1. Cut or Copy the item you want to Paste. 

2. Reposition the insertion point at the target location. 

3. On the Edit Menu, select Paste . 

 

If the text contains formatting from Word, you will receive a message ñThe text you 
want to paste seems to be copied from Word. Do you want to clean it before 
posting?ò Refer to Paste from Word below. 

If the text contains formatting from non-Word applications, the HTML editor will 
copy the formatting when the item is pasted. 

Paste as plain text  

1. Cut or Copy the item you want to Paste. 

2. Reposition the insertion point at the target location. 

3. On the Edit Menu, select Paste . 

Paste  from Word  

1. Cut or Copy the item you want to Paste. 

2. Reposition the insertion point at the target location. 

3. On the Edit menu, select Paste from Word . 
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4. Do you want to clean the text before posting? 

If Then 

Yes 1. Click OK. 

2. In Paste from Word: 

 

a. Paste your text in the box provided. 

b. Check Ignore Font Face definitions to remove the Word font 
styles. 

c. Check Remove Style definitions to remove the Word formatting 
styles. 

d. Click OK. 

No Your text is pasted from Word, applying the Word styles and formatting.   

 

Find  

1. On the Edit Menu, select Find . 



A N G E L ®  H T M L  E D I T O R  R E F E R E N C E  M A N U A L  

27  

2. On the Find dialog, complete the following fields: 

 

Field Description 

Find What The text you want to search for. 

Match case Match the case format. 

Match whole 
word 

Match the full word(s). Ignores partial matches. 

a. Click Find. 

b. Click Cancel to close the dialog. 

Replace  

1. On the Edit Menu, select Replace . 

2. On the Replace dialog, complete the following fields: 

 

Field Description 

Find What The text you want to search for. 

Replace With The replacement text. 

Match case Match the case format. 
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Field Description 

Match whole 
word 

Match the full word(s). Ignores partial matches. 

a. Click Replace or Replace All. 

b. Click Cancel to close the dialog. 

Select All  

To select all text: 

 On the Edit menu, select Select All .  

Remove format  

1. Select the text from which you want to remove formatting. 

2. On the Edit menu, select Remove Format .  
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Creating Macros  

Macros are preprogrammed shortcuts which perform a series of actions. Macros can be created 
and shared across courses, groups and resource libraries to which you have editor access.  The 
creation of macros allows you to create the item once and use it multiple times in your courses, 
groups or resource libraries. 

For example, if youôd like to automatically insert a salutation (e.g. Hello class!) at the beginning 
of each page, you can create a macro which allows you to insert the phrase, versus retyping it 
for every page. 

After your macro has been created you can use it on the page you are creating or share it in 
other course, groups or resource libraries to which you have editing rights. 

The following is a list of macro tools: 

Icon Description 

 
Insert/Edit Macro- allows you to create or edit shortcuts that perform a 
series of actions 

Create a new Macro  

1. Click Insert/Edit Macro . 

2. Click the New Macro tab. 

3. In the New Macro tab, complete the following fields: 
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Field Action 

Name The name of your macro. 

Category The category for the macro. Do one of the following to define the 
category: 

 Chose the category from the drop-down-down list . 

 Click the new macros button to create a new category 

Macro 
text 

The text to be inserted into the text area when the macro is played.  
Formatting of the text requires HTML tags.  

4. Click Save. 

Edit a Macro  

1. Click Insert/Edit Macro . 

2. On the Macro dialog, select the Category from the drop-down-down list.   

3. Select the macro you want to edit and click Edit. 

4. On the Existing Macros tab: 

 

a. Update the name, category and macro text as necessary. 

b. Click Save.   
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To apply the updated macros to your new page, you will need to use the Insert a 
Macros function. 

You can past HTML from Source, but not from the editor window. 

Insert a Macro  

1. Click Insert/Edit Macro . 

2. On the Macro dialog 

 

a. Select the Category from the drop-down-down list.   

b. Click the macro you want to insert from the category on the left side of the 
window. 

c. Click the OK button.   

Delete a Macro  

1. Click the Insert/Edit Macro icon.  
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2. On the Macro dialog: 

 

 

a. Select the Category from the drop-down-down list.   

b. Click the macro you want to delete. 

c. Click Delete. You are prompted, ñPermanently delete this item?ò  

If Then 

Yes Click OK to delete the macros from your list and from the Category 
options.  

No Click Cancel to return you to the Existing Macros tab. 

 

d. Click the OK button.   

Share a Macro  

1. Click the Insert/Edit Macro icon.  

2. On the Macro dialog, select the Category from the drop-down-down list.  Your list of 
macros from that category is listed in the text area on the left side. 

3. Select the macro you want to share. 
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4. Click Share. 

 

5. Complete the following fields: 

Field Description 

Share withé The minimum course rights required to use the shared macro. 

In these sectionsé The course/group section to share the macro with. 

6. Click Save. 
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Inserting Hyperlinks  

A hyperlink is a link from one page or file to another. On a page, you may want to insert a 
hyperlink to some other website or to a document you uploaded to you server. A hyperlink is 
usually displayed by a distinguishing feature such as a different color, font or style. When a 
hyperlink is clicked, the destination is displayed, opened, or run, depending on the type of 
destination. The destination is frequently another page, but it can also be a picture, a multimedia 
file, a document, an e-mail address, or a program. 

 

To create, edit and remove hyperlinks, you will use the following tools found on the Link Menu: 

 

Icon Description 

 

 

 

Insert/Edit Web Link - Add or remove hyperlink from highlighted 
text. Used to add or edit links outside the ANGEL environment or 
an anchor within a page. 

 

 

Insert Content Link - Used to create links to areas in system where 
links exisit or will exist based on an upload. 

 
Remove Link - allows you to remove a hyperlink youôve inserted in 
a page. 

 
Anchor - allows you to create bookmarks within pages inside and 
outside of ANGEL. 

Web Link  

A web link is used to create a reference or navigation element to another section of the same 
page, to an email or to another page on the internet. 

Create a l ink  to a  web address ( URL ) 

1. Select the text or image you want to use as the hotspot for the link. 
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2. Click Web Link . 

 

3. On the Link info tab, complete the following fields: 

Field Description 

Link Type Specifies link type (e.g. URL, Link to anchor in the text, E-mail). For a 
web link to a page on the internet, select URL. 

Protocol Specifies the protocol from the drop-down list. (e.g. http, https, ftp, 
news, other). 

URL Specifies the URL or address of the web page the link will display. 
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4. Click the Target tab. 

 

5. Optionally, complete the following fields: 

Field Description 

Target Type 

 

Select the Target Type from the drop-down list.  

 Frame: A frame within the current frame. 

 Pop-up Window: Opens in a pop-up window. 

 New Wndow: Opens in a new window. 

 Topmost Window: Opens in topmost window which 
replaces your current window. 

 Same Widow:  Opens in the same window you are using. 

 Parent Window:  Opens in new window unless you are in 
frames.  

Target Frame 
Name box 

When using the target type of Frame, this specifies the name of 
the frame the target displays. 
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6. Click the Advanced tab. 

 

7. Optionally, complete the following: 

Field Description 

Id The id attribute may be used to create an anchor at the start tag 
of any HTML element. (HTML Id attribute). 

Language 
Direction 

Specifies the base direction of directionally neutral text. Possible 
values:  

 Left-to-right  

 Right-to-left  

Access Key A single character that defines the shortcut key (ALT + character) 
that "clicks" on the link.  

Name The anchor name.  Used to link to an anchor within a page. 

Language 
Code 

Specifies the base language of the target URL. 

Tab Index Defines the position in tabbing order. 

Advisory Title Defines the text that displays when the user moves the mouse 
over the link. 

Advisory 
Content Type 

Provides gives an advisory hint as to the content type of the 
target URL. Examples include "text/html", "image/png", 
"image/gif", "video/mpeg", "text/css", etc. 

Stylesheet 
Classes 

Assigns a class name or set of class names to an element. 
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Field Description 

Linked 
Resource 
Charset 

Specifies the character encoding of the target URL.  

Style Allows entry of custom CSS style information for the element. 

8. Click OK. 

Create a link to an e -mail address  

1. Click Web Link . 

2. On the Link info tab, select E-mail from the Link Type. 

 

3. Complete the following fields: 

Field Description 

E-mail 
Address 

The recipients email address 

Message 
Subject 

The subject of the message to be sent. 

Message 
Body 

The information to be contained in the message body. 
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9. Click the Advanced tab. 

 

10. Optionally, complete the following: 

Field Description 

Id The id attribute may be used to create an anchor at the start tag 
of any HTML element. (HTML Id attribute). 

Language 
Direction 

Specifies the base direction of directionally neutral text. Possible 
values:  

 Left-to-right  

 Right-to-left  

Access Key A single character that defines the shortcut key (ALT + character) 
that "clicks" on the link.  

Name The anchor name.  Used to link to an anchor within a page. 

Language 
Code 

Specifies the base language of the target URL. 

Tab Index Defines the position in tabbing order. 

Advisory Title Defines the text that displays when the user mousse-over the 
link. 

Advisory 
Content Type 

Provides gives an advisory hint as to the content type of the 
target URL. Examples include "text/html", "image/png", 
"image/gif", "video/mpeg", "text/css", etc. 

Stylesheet 
Classes 

Assigns a class name or set of class names to an element. 
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Field Description 

Linked 
Resource 
Charset 

Specifies the character encoding of the target URL.  

Style Allows entry of custom CSS style information for the element. 

 

11. Click OK. 

Edit web link  

1. Right-click on the hyperlink and click Edit Link. 

Remove web link  

2. Select the hyperlink you want to remove. 

3. Do one of the following: 

 On the File Menu, select Remove Link . 

or 

Click the Insert/Edit Content Link . 

 In the URL box, highlight the URL and press Delete. 

or  

Right-click on the hyperlink and click Remove Link. 

Content Link  

A content link is used to create a reference or navigation element to an item within the ANGEL 
LMS environment.  There are five different areas which you can link to from a course: 

Content 
Area 

Description 

Personal 
Files 

Personal Files allows you to link to files stored in your personal file manager 
(within the Toolbox select Personal Home page > Files link). This is useful for 
users who want to link to the same file resource from multiple courses or 
locations. This approach is not recommended when building a master course 
image that will be used by multiple instructors because the source image 
would be deleted in the event the instructorôs account is ever deleted from the 
system. 

Associated 
Files 

Associated Files displays all file resources (html page, images, PowerPoint, 
Adobe .pdf, etc.) uploaded to the current content item. This is the 
recommended location for file resources if the content item needs to remain 
portable ï meaning that the content item (quiz, page, folder, etc.) needs to 
support export to a different course or location as is commonly the case with 
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Content 
Area 

Description 

content items in learning object repositories. When a content item is exported 
or copied from another course, all file resources for the content item are 
exported/copied as well. 

Course Files Course Files displays the root view of all associated files for all content items 
in the course. This option can be helpful when dealing with multiple content 
items that need to the same file resources within the course (i.e. repeated 
course images, etc.). File resources within the course file manager are always 
exported with the course, but are not included when importing/exporting a 
single content item (i.e. from a repository). Therefore, this approach can be 
effective for individual instructor courses and master courses, but should not 
be used to store file resources for repository content items. 

 
WebCT/Bb/IMS/Standard Zip Import all place their files in the 
Course Files area. 

  

Map The Map displays a birds-eye view of the course content, course tabs and 
select course tools/reports allowing the editor to create links to specific 
content items, tools or tabs. If HTML anchors exist in the page item or an 
uploaded webpage, the appropriate syntax (i.e. #anchor1) can be added to 
the end of the resultant link to provide direct navigation to that portion of the 
document. 

Icons The Icons area displays a list of image resources that has been populated by 
your institutions ANGEL Administrator. This option can be helpful when 
dealing with content which applies to any course/group within the system (e.g. 
logo's, banners, icons). The location of these icons is in the 
...\AngelThemes\System\Icons\ area within ANGEL. 

 

Insert content link  

1. Do one of the following: 

 Select Insert Content Link.  

 On the Link Menu, select Content Links . 

2. On the Content Links dialog, do the following: 

 Choose the tab for which you need to upload files. 

 Click New Folder to create a new folder, if applicable. 

3. On the tab(s) youôve selected, do the following:  

 Click Browse and select a file. (Available for Personal, Associated or Course 
only.) 

 Click Upload File. 
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or 

 In the Path box, select an existing file, map path or icon. Your link will be inserted 
into the HTML editor window.  

Edit content link  

1. Right-click on the hyperlink and click Edit Link. 

2. On the Content Links dialog, edit the hyperlink properties. 

3. Click OK. 

Remove content link  

1. Select the hyperlink you want to remove. 

2. Do one of the following: 

 On the File Menu, select Remove Link . 

or 

Click the Insert/Edit Content Link . 

 In the URL box, highlight the URL and press Delete. 

or  

Right-click on the hyperlink and click Remove Link. 

 

Using Anchors  

An essential feature of a web pages is the ability to connect (hyperlink) pages, media files and 
programs.  A hyperlink can be made from one resource to another or from one location within a 
resource to another. Both the source and the destination of a link are anchors (sometimes 
called bookmarks). 

For example, you may have a page with several topics. At the end of each topic, you may want 
to include an anchor which when clicked will bring users back to the top of a topic or back to the 
table of contents. 

Creating an anchor is a two step process. First, you will create an anchor and then you will 
create a link to the anchor.   

When creating an anchor, naming it is very important. The name is an opportunity to remember 
for what purpose you created it. In the example above, you might name your anchor ótopô, which 
signifies that by clicking the anchor, you will be returned to the top of a page or section. 

Some other tips for naming your anchors: 

 Create short, one word names. 

 Do not use underscores ( _ ). 

 Do not use uppercase letters. Some web browsers differentiate between upper and 
lowercase. 
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 Do not include punctuation marks or symbols. 

 Do not use numbers. 

Add an a nchor  

1. Position the insertion point at the target location. 

2. On the File Menu, select Anchor . 

 

3. In the Anchor Properties dialog, type the Anchor Name.  The anchor icon  will 
appear at the anchor point. 

I nsert a link to an anchor  

1. Select the text or image you want to use as the hotspot for the link. 

2. Click Web Link . 

3. On the Link tab, select Link to anchor in text from the Link Type list.  

 

4. Complete one of the following: 
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 Select an anchor by Anchor Name. 

 Select an anchor by Element Id. 

5. Click OK. 
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Tables  

A table is made up of columns and rows of cells into which you can insert text and graphics.  
There are several different ways you can use tables, and you can customize your tables in a 
variety of ways to make them more attractive and easy to read. 

The tables tool allows you to arrange data such as text, images, links, forms, etc. into columns 
and rows of cells.   

Create a table and set its properties  

1. Position the insertion point where you want to insert the table.  

2. Do one of the following: 

 Click Insert/Edit Table .  

 Click the Table Menu and select Insert/Edit Table . 

 

3. Complete the following: 

Field Name Description 

Rows Specifies the number of rows.  

Columns Specifies the number of columns.  

Alignment Specifies the position for the table on the page.  

Width Specifies the width of the table in either pixels or as a percentage 
of the window width. 

Height Specifies the height of the table in pixels. 

Border size Specifies the width you want for the table border in pixels. If you 
do not want a border, type 0.  
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Field Name Description 

Cell spacing Specifies a number in the Cell padding box.  

Cell padding Specifies a number in the Cell spacing box.  

Caption Specifies a caption in the Caption box. 

Summary Specifies a summary of the table for use with speech-synthesizing/ 
non-visual browsers, if applicable. 

 

4. Click OK. 

 
When a table is present on your page you can right-click in the table and a pop-up 
menu is presented with possible table operations. 

Cell Properties  

Tables are comprised of cells. Each cell can be formatted by using cell properties.  

Set the properties of a table cell  

1. Select the cells you want to change.  

2. Right-click, and then click Cell > Cell Properties on the pop-up menu.  

 

3. Complete the following fields: 

Field Name Description 

Width Specifies the size of the cell width in either pixels or as a percent. 

Height Specifies the size of the cell height in pixels. 

Word Wrap Allows text to wrap in a cell  
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Field Name Description 

Horizontal 
Alignment 

Specifies the horizontal position for the text within the cell.  

Vertical 
Alignment 

Specifies the vertical position for the text within the cell. 

Row Span Specifies the number of rows you want the cells to span.  

Column Span Specifies the number of columns you want the cells to span.  

Background 
Color 

Specifies the color background. 

Border Color Specifies the border color of tables. 

 

4. Click OK. 

Add a cell, row, or column to a table  

In sert a cell  

1. Position the insertion point in a cell to the left of where you want to add a cell.  

2. On the Table menu of the toolbar, select Insert Cell . 

Insert a row  

1. Position the insertion point in a cell above where you want to add a new row.  

2. On the Table menu of the toolbar, select Insert Row . 

Insert a column  

1. Position the insertion point in a cell to the left of where you want to add a new 
column.  

2. On the Table menu of the toolbar, select Insert Column . 

Insert a table within a table  

1. Position the insertion point in a cell where you want to add a new table.  

2. Do one of the following: 

 Click Insert/Edit Table. 

 On the Table menu of the toolbar, select Table . 

Formatting  table cells  
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Split cells  

1. Position the insertion point in the cell you want to divide.  

2. Right-click the cell and then click Cells > Split Cells on the pop-up menu. 

Merge cells  

1. Select the cells you want to combine.  

2. Right-click the selection and then click Cells > Merge Cells on the pop-up menu. 

Delete all or part of  a table  

Delete a table  

1. Select the cells you want to delete.  

2. Right-click and select Delete Table on the pop-up menu. 

Delete a cell  

1. Select the cells you want to delete.  

2. On the Table menu of the toolbar, select Delete Cell . 

Delete a row  

1. Select the rows you want to delete.  

2. On the Table menu of the toolbar, select Delete Row . 

Delete a column  

1. Select the columns you want to delete. 

2. On the Table menu of the toolbar, select Delete Column . 
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Inserting Image, Flash and Movies  

In the  HTML editor, you can add images, Flash presentations and movies. These elements 
visually enhance your pages as well as provide rich content for a variety of audiences and 
learning types. 

You can use images on your page for a variety of reason. In addition to being decorative, 
graphics can be useful in providing information, examples or even navigational buttons.  

The Media menu, contains the following tools: 

Icon Description 

 

 

Image - inserts an image (e.g. .jpg, .tiff, .bmp) 

 
Flash - inserts a Flash presentation file. 

 
Movie - inserts a movie file. This could be an .mp3, au, avi, wmvé 

 

Using Images  

Images are a good way to make your content more visual. Images can include elements such 
as logos, line art, simple graphics.  There are several image formats that can be used on the 
internet.  The following are the most common.   

Format Description 

.gif GIF (Graphics Interchange Format) is an 8-bit-per-pixel bitmap image format that 
was introduced by CompuServe in 1987 and has since come into widespread 
usage on the World Wide Web due to its wide support and portability. 

The format uses a palette of up to 256 distinct colors. It also supports animations 
and allows a separate palette of 256 colors for each frame.  

.jpg JPEG (Joint Photographic Experts Group) provides for lossy compression of 
images. The file format is typically used for high-end images or photographs.    

The format uses a palettes of  16.7 million colors. 

.png PNG (Portable Network Graphics) is a bitmapped image format that employs 
lossless data compression. PNG was created to improve and replace the GIF 
format, as an image-file format not requiring a patent license.  

The format uses a palettes of 24-bit RGB colors or grayscale. 

   

Add images   
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1. Position your cursor where you want to insert the image. 

2. Do one of the following 

 Click the Insert/Edit image .  

 On the Media Menu, select Image . 

 

3. On the Image Properties dialog, complete the Image Info tab: 

Field Description 

URL The web address of the image to display.  Click Browse to 
navigate to the image location. 

Alternative Text Used by Web browsers to display text during image downloads 
for users who have graphics turned off, and for users who rely 
on screen-reading software to convert graphics on the screen to 
spoken words.  

Width Sets the width of an image.  Can be enters in pixels or as a 
percentage. 

Height Sets the height of an image.  Can be enters in pixels or as a 
percentage. 

 Lock Ratio Select to lock image aspect ratio (relationship of the height and 
width of an image).  When selected, re-sizing wither the height 
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Field Description 

or width automatically maintains the ratio of the other. 

 Reset Size Select to reset the image to its original size. 

Border The size of the border in pixels around the graphic. This is a 
way to indicate that they can click the graphic. 

HSpace Defines white space, in pixels, on the left and right side of the 
image. 

VSpace Defines white space, in pixels, on the top and bottom of the 
image. 

Align Specifies how to align the image according to surrounding text. 
Left - Aligns the image will be left justified. Text will begin at the 
top of right of the image 

 Abs Bottom - Aligns the bottom of the first line of text with 
the bottom of the image 

 Abs Middle - Aligns the top of the first line of text with the 
middle of the image 

 Baseline - Aligns the bottom of the image with the baseline 
of the text. The baseline is the line along which the bottom 
of most letters rest, but below which some letters dangle, 
such as j and y.  

 Bottom  - Aligns the bottom of the image aligns with the 
baseline of the line containing the image. 

 Middle - Aligns the center of the image aligns with the 
bottom of the first text line  

 Right - Aligns the image will be right justified. Text will start 
at the top left of the image 

 Text Top - Aligns the first line of text will align with the top of 
the image.  

 Top - Aligns the top of the image aligns with the tallest item 
on the line containing the image. 

 

4. If the image to be used as a hyperlink. Click the Link tab. 
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5. On the Link tab, complete the following: 

 

Field Description 

URL The web address of the link to display when the image is 
clicked.  Click Browse to navigate to the link page. 

Target Select the Target from the drop-down list.  

 New Window (_blank): Opens in a new window. 

 Topmost (_top): Opens in topmost window which replaces 
your current window. 

 Same Widow (_self):  Opens in the same window as the 
image. 

 Parent Window (_parent):  Opens in new window.. 

 

6. Optionally, click the Advanced tab 
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7. Optionally, complete the following: 

Field Description 

Id The id attribute may be used to create an anchor at the 
start tag of any HTML element. (HTML Id attribute). 

Language 
Direction 

Specifies the base direction of directionally neutral text. 
Possible values:  

 Left-to-right  

 Right-to-left  

Language 
Code 

Specifies the base language of the target URL. 

Long 
Description 
URL 

Specifies the URL of a document that contains an 
extended description of the resource. 

Stylesheet 
Classes 

Assigns a class name or set of class names to an 
element. 

Advisory Title Defines the text that displays when the user mousse-over 
the link. 

Style Allows entry of custom CSS style information for the 
element. 
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8. Click OK. 

 
Click Cancel to exit the window without making changes. 

Using  Flash  

Flash, refers to both the Adobe Flash Player and to a multimedia authoring program used to 
create content (such as web applications, games and movies).  Flash presentations are a good 
way to add interactive content to your pages.  

Adding Flash presentations   

1. Position your cursor where you want to insert the Flash presentation. 

2. On the Media Menu, select Flash . 

 

3. On the Flash Properties dialog Info tab, complete the following fields: 

Field Description 

URL Specifies a web address of the Flash file.  Select the browse button 
to navigate to the file if it is located in the course or is to be uploaded 
to the course. 

Width Specifies the width to display the Flash presentation in pixels. 


